InfoNu.nl > Pc en Internet > Software > Excel formules: AANTAL.ALS en SOM.ALS

Excel formules: AANTAL.ALS en SOM.ALS

Excel formules: AANTAL.ALS en SOM.ALS De formules AANTAL.ALS en SOM.ALS zijn eenvoudiger te maken dan je denkt. De AANTAL.ALS formule wordt gebruikt om het totaal aantal in een bereik te berekenen als deze voldoet aan een bepaalde voorwaarde (oftewel criterium). Met de SOM.ALS formule kun je het somtotaal uitrekenen van een bereik (optelbereik) wanneer deze aan een bepaalde voorwaarde (criterium) voldoet, die zich echter in een ander bereik bevindt.

Inhoud AANTAL.ALS EN SOM.ALS formules in Excel 2000


AANTAL.ALS

Stel, je geeft een feest en wilt weten hoeveel van de genodigden er zullen komen. Meestal heb je in Excel al een adressenlijst beschikbaar van wie je hebt uitgenodigd. Je kunt hiervoor de volgende formule gebruiken: =AANTAL.ALS(bereik;criterium).

  1. Voeg aan deze lijst een nieuwe kolom A toe en geef cel A1 als titel JA/NEE (klik op de huidige kolom A, zodat de gehele kolom A wordt geselecteerd, vervolgens rechter muisknop, kies Invoegen).
  2. Vul in de nieuwe kolom A bij elke genodigde in of hij wel (JA) of niet (NEE) komt.
  3. Kies een cel waarin het resultaat moet komen te staan en typ dan deze formule in: =AANTAL.ALS(bereik in kolom A;”JA”) met als bereik in kolom A bijv. A2:A10, als de eerste genodigde in rij 2 staat en de laatste in rij 10. De formule ziet er dan als volgt uit: =AANTAL.ALS(A2:A10;"JA").
  4. Druk op ENTER.

Let op:
  • Door "JA" als criterium te gebruiken, is meteen duidelijk welk criterium je hebt gebruikt. Het is echter ook mogelijk een verwijzing te maken naar een cel in kolom A waarin JA is ingevuld. Stel, JA is ingevuld in cel A3, dan ziet de formule er als volgt uit: =AANTAL.ALS(A2:A10;A3). Nadeel hiervan is dat je dan moet opzoeken welk criterium is gebruikt.
  • Het criterium kan zowel tekst ("JA") als getallen bevatten, bijv. "2" (als je bijv. wilt tellen hoe vaak 2 voorkomt in de lijst).
  • Wanneer je een criterium invult, maakt het niet uit of je hoofdletters of kleine letters gebruikt.

SOM.ALS

Met de AANTAL.ALS formule kun je helaas niet het totaal aantal mensen, dat komt, berekenen. Hiervoor heb je de SOM.ALS formule nodig, die er als volgt uitziet: =SOM.ALS(bereik;criterium;optelbereik).

  1. Voeg dan aan de lijst een nieuwe kolom A toe en geef cel A1 als titel AANTAL.
  2. Vul in de nieuwe kolom A bij elke genodigde in hoeveel mensen er in totaal komen (0, 1, 2, 3, etc.).
  3. Kies een cel waarin het resultaat moet komen te staan en typ dan in:=AANTAL.ALS(bereik in kolom A;”>0”) met als bereik in kolom A bijv. A2:A10, als de eerste genodigde in rij 2 staat en de laatste in rij 10. Het criterium ">0" betekent dat je de totale som wilt berekenen van alles wat groter is dan 0. Het ziet er dan als volgt uit: =SOM.ALS(A2:A10;">0").
  4. Druk op ENTER.

Let op:
  • De SOM.ALS formule bestaat uit drie componenten: bereik, criterium en optelbereik. Hier is het optelbereik achterwege gelaten, omdat deze in dit voorbeeld hetzelfde is als het (cel)bereik. Stel, je hebt in kolom A aangegeven of genodigden wel of niet komen (titel JA/NEE) en in kolom B met hoeveel mensen ze komen (titel AANTAL), dan ziet de formule er als volgt uit: =SOM.ALS(A2:A10;"JA";B2:10). Deze formule zegt niets anders dan: wanneer in bereik A2:A10 JA is ingevuld, dan moet je de waardes in bereik B2:B10 optellen. Je gebruikt dan alle drie componenten.
  • Je kunt in dit geval de SOM.ALS formule omzeilen door een simpele som-formule te maken (in de eerstvolgende lege cel in de nieuw toegevoegde kolom gebruik je de toetscombinatie Alt+=; het bereik wordt dan automatisch voor je ingevuld).

Tip bij aanwezigheidslijsten

Bij het bijhouden van aanwezigheidslijsten raad ik aan om een kolom te gebruiken met de titel "JA/NEE", waarin je aangeeft of je een reactie wel (JA) of niet (NEE) hebt ontvangen met daarnaast nog een kolom met de titel "AANTAL", waarin je invult hoeveel personen er komen. Op deze manier kun je bijhouden hoeveel reacties je hebt terugontvangen. Bovendien is het logisch dat mensen wel of niet komen, wanneer er een getal is ingevuld in de kolom "AANTAL". In combinatie met de formules kun je het programma het werk voor je laten doen.

Lees verder

© 2012 - 2017 Juliejulie, het auteursrecht van dit artikel ligt bij de infoteur. Zonder toestemming van de infoteur is vermenigvuldiging verboden.
Gerelateerde artikelen
Excel Formules - Verticaal ZoekenExcel Formules - Verticaal ZoekenMicrosoft Excel is een software programma dat binnen bedrijven, scholen en/of privé huishouding gebruikt wordt om dageli…
De functies in ExcelDe functies in ExcelHierin zullen verschillende functies die in Excel gebruikt kunnen worden naar boven komen. Deze zullen uitgelegd worden…
Excel 2010, tips & trucsExcel 2010, tips & trucsMicrosoft Office Excel is hét digitale rekenblad programma dat er is. Excel is een onderdeel van het Microsoft Office pa…
Het programma Excel downloadenHet programma Excel downloadenExcel is een programma dat is ontworpen door Microsoft. Het doet dienst als digitaal rekenblad op het besturingssysteem…
Scheikunde - rekenen met molScheikunde - rekenen met molMol is een rekenhulp die vaak gebruikt wordt in de scheikunde. Het geeft eigenlijk aan hoeveel er van een bepaalde stof…
Bronnen en referenties
  • http://office.microsoft.com/

Reageer op het artikel "Excel formules: AANTAL.ALS en SOM.ALS"

Plaats als eerste een reactie, vraag of opmerking bij dit artikel. Reacties moeten voldoen aan de huisregels van InfoNu.
Meld mij aan voor de tweewekelijkse InfoNu nieuwsbrief
Infoteur: Juliejulie
Laatste update: 21-02-2012
Rubriek: Pc en Internet
Subrubriek: Software
Bronnen en referenties: 1
Schrijf mee!